» » Уязвимость в SocialEngine 4.x.x - 12.03.2011

Уязвимость в SocialEngine 4.x.x - 12.03.2011

Система: SocialEngine 4.x.x

Опасность: Высокая


Описание: Обнаружена уязвимость в безопасности влияющая на SocialEngine Core (до версии 4.1.2p1) и плагин Форум (Forum) (вплоть до версии 4.1.2). Использование уязвимости позволяет зарегистрированным пользователем удалять содержимое форума не принадлежащее им. Уязвимость не угрожает целостности вашего сервера и всей системе SocialEngine, но представляет высокую угрозу и должна быть устранена.

URL производителя: www.socialengine.net

Решение: Для обновления плагина Форум (Forum), Войдите в клиентскую область и скачайте последнею версию плагина Форум (версия 4.1.2p2), и следуйте инструкциям по установки пакета.
Для решения проблемы с SocialEngine Core, вы можете скачать патч [170 Kb] (cкачиваний: 89). Следуйте инструкции по установке пакета для выполнения обновления.

Если вы хотите произвести ручное исправление, просто откройте /application/modules/Authorization/Controller/Action/Helper/RequireAuth.php на строке 61, Вы должны увидеть следующее:

public function setAuthParams($resource = null, $role = null, $action = null)
  {

Замените верхний код на:
public function setAuthParams($resource = null, $role = null, $action = null)
  {
$this->clearAuthParams();


Разработчики приносят извинения за причиненные неудобства, ибо очень серьезно относятся к вопросам безопасности. Если у вас есть какие-либо вопросы, пожалуйста, не стесняйтесь обращаться к нам или оставляйте комментарии здесь.

Другие публикации по теме:

Комментарии